<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" lang="en-US" xml:lang="en-US" prefix="og: http://ogp.me/ns#">
<head profile="http://gmpg.org/xfn/11">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<title>450 flames light torch parade - The Wichitan</title>
		<style type="text/css">
			.slide-excerpt { width: 30%; }
			.slide-excerpt { bottom: 0; }
			.slide-excerpt { right: 0; }
			.flexslider { max-width: 600px; max-height: 400px; }
			.slide-image { max-height: 400px; }
		</style>
		<style type="text/css">
			@media only screen
			and (min-device-width : 320px)
			and (max-device-width : 480px) {
				.slide-excerpt { display: none !important; }
			}
		</style> 
<!-- This site is optimized with the Yoast SEO plugin v5.2 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://thewichitan.com/450-flames-light-torch-parade/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="450 flames light torch parade - The Wichitan" />
<meta property="og:description" content="Campus streets radiated with the warm light of 450 torches held by students as they marched toward the bonfire. Students, faculty and staff alike took part in the torchlight parade leading to the homecoming events Oct. 19. Student organizations took part in presenting the final round of the lip-sync competition, where Alpha Psi Omega, the &hellip;" />
<meta property="og:url" content="http://thewichitan.com/450-flames-light-torch-parade/" />
<meta property="og:site_name" content="The Wichitan" />
<meta property="article:publisher" content="https://www.facebook.com/thewichitan/" />
<meta property="article:tag" content="bonfire" />
<meta property="article:tag" content="homecoming" />
<meta property="article:tag" content="lip sync" />
<meta property="article:tag" content="midwestern state" />
<meta property="article:tag" content="torches" />
<meta property="article:tag" content="torchlight parade" />
<meta property="article:section" content="Campus" />
<meta property="article:published_time" content="2017-10-20T10:36:37-05:00" />
<meta property="article:modified_time" content="2017-10-20T10:39:13-05:00" />
<meta property="og:updated_time" content="2017-10-20T10:39:13-05:00" />
<meta property="og:image" content="http://thewichitan.com/wp-content/uploads/2017/10/flames_008.jpg" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="683" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Campus streets radiated with the warm light of 450 torches held by students as they marched toward the bonfire. Students, faculty and staff alike took part in the torchlight parade leading to the homecoming events Oct. 19. Student organizations took part in presenting the final round of the lip-sync competition, where Alpha Psi Omega, the [&hellip;]" />
<meta name="twitter:title" content="450 flames light torch parade - The Wichitan" />
<meta name="twitter:site" content="@wichitanonline" />
<meta name="twitter:image" content="http://thewichitan.com/wp-content/uploads/2017/10/flames_008.jpg" />
<meta name="twitter:creator" content="@wichitanonline" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Wichitan &raquo; Feed" href="http://thewichitan.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Wichitan &raquo; Comments Feed" href="http://thewichitan.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Wichitan &raquo; 450 flames light torch parade Comments Feed" href="http://thewichitan.com/450-flames-light-torch-parade/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/thewichitan.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.2"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b!==c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='flagallery-css'  href='http://thewichitan.com/wp-content/plugins/flash-album-gallery/assets/flagallery.css?ver=5.1.2' type='text/css' media='all' />
<link rel='stylesheet' id='lifestyle-theme-css'  href='http://thewichitan.com/wp-content/themes/lifestyle/style.css?ver=2.5.2' type='text/css' media='all' />
<link rel='stylesheet' id='social-widget-css'  href='http://thewichitan.com/wp-content/plugins/social-media-widget/social_widget.css?ver=4.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='http://thewichitan.com/wp-content/plugins/wp-polls/polls-css.css?ver=2.73.7' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background: #f0bb39;
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='slider_styles-css'  href='http://thewichitan.com/wp-content/plugins/genesis-responsive-slider/style.css?ver=0.9.5' type='text/css' media='all' />
<script type='text/javascript' src='http://thewichitan.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://thewichitan.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://thewichitan.com/wp-content/plugins/dropdown-menu-widget/scripts/include.js?ver=4.8.2'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='http://thewichitan.com/wp-content/themes/genesis/lib/js/html5shiv.js?ver=3.7.3'></script>
<![endif]-->
<script type='text/javascript' src='http://thewichitan.com/wp-content/plugins/google-analyticator/external-tracking.min.js?ver=6.5.4'></script>
<link rel='https://api.w.org/' href='http://thewichitan.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://thewichitan.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://thewichitan.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.8.2" />
<link rel='shortlink' href='http://thewichitan.com/?p=43967' />
<link rel="alternate" type="application/json+oembed" href="http://thewichitan.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fthewichitan.com%2F450-flames-light-torch-parade%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://thewichitan.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fthewichitan.com%2F450-flames-light-torch-parade%2F&#038;format=xml" />
<link type="text/css" rel="stylesheet" href="http://thewichitan.com/wp-content/plugins/simple-pull-quote/css/simple-pull-quote.css" />

<!-- <meta name='Grand Flagallery' content='5.1.2' /> -->
<link rel="icon" href="http://thewichitan.com/wp-content/themes/lifestyle/images/favicon.ico" />
<link rel="pingback" href="http://thewichitan.com/xmlrpc.php" />
<link href='http://fonts.googleapis.com/css?family=Arvo:400,700|Bitter:400,700|Open+Sans:400,600,700' rel='stylesheet' type='text/css'><style type="text/css">#header { background: url(http://thewichitan.com/wp-content/uploads/2012/09/header.png) no-repeat !important; }</style>
		<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
		

<!-- Dropdown Menu Widget Styles by shailan (http://metinsaylan.com) v1.9.6 on wp4.8.2 -->
<link rel="stylesheet" href="http://thewichitan.com/wp-content/plugins/dropdown-menu-widget/css/shailan-dropdown.min.css" type="text/css" />
<link rel="stylesheet" href="http://thewichitan.com/wp-content/plugins/dropdown-menu-widget/themes/web20.css" type="text/css" />
<style type="text/css" media="all">
	ul.dropdown { white-space: nowrap; }
	/* Selected overlay:  */
	.shailan-dropdown-menu .dropdown-horizontal-container, ul.dropdown li{ background-color:; }
	ul.dropdown a,
	ul.dropdown a:link,
	ul.dropdown a:visited,
	ul.dropdown li { color: ; }
	ul.dropdown a:hover,
	ul.dropdown li:hover { color: ; }
	ul.dropdown a:active	{ color: ; }

	ul.dropdown li.hover a, ul.dropdown li:hover a{ background-color: ; }
	ul.dropdown li.hover ul li, ul.dropdown li:hover ul li{ background-color: ;
		color: ; }

	ul.dropdown li.hover ul li.hover, ul.dropdown li:hover ul li:hover { background-image: none; }
	ul.dropdown li.hover a:hover, ul.dropdown li:hover a:hover { background-color: ; }

	ul.dropdown ul{ background-image:none; background-color:; border:1px solid ; }
	ul.dropdown-vertical li { border-bottom:1px solid ; }
	
	/** Show submenus */
	ul.dropdown li:hover > ul, ul.dropdown li.hover ul{ display: block; }

	/** Show current submenu */
	ul.dropdown li.hover ul, ul.dropdown ul li.hover ul, ul.dropdown ul ul li.hover ul, ul.dropdown ul ul ul li.hover ul, ul.dropdown ul ul ul ul li.hover ul , ul.dropdown li:hover ul, ul.dropdown ul li:hover ul, ul.dropdown ul ul li:hover ul, ul.dropdown ul ul ul li:hover ul, ul.dropdown ul ul ul ul li:hover ul { display: block; }

			
ul.dropdown li.parent>a{
	padding-right:25px;
}
ul.dropdown li.parent>a:after{
	content:""; position:absolute; top: 45%; right:6px;width:0;height:0;
	border-top:4px solid rgba(0,0,0,0.5);border-right:4px solid transparent;border-left:4px solid transparent }
ul.dropdown li.parent:hover>a:after{
	content:"";position:absolute; top: 45%; right:6px; width:0; height:0;
	border-top:4px solid rgba(0,0,0,0.5);border-right:4px solid transparent;border-left:4px solid transparent }
ul.dropdown li li.parent>a:after{
	content:"";position:absolute;top: 40%; right:5px;width:0;height:0;
	border-left:4px solid rgba(0,0,0,0.5);border-top:4px solid transparent;border-bottom:4px solid transparent }
ul.dropdown li li.parent:hover>a:after{
	content:"";position:absolute;top: 40%; right:5px;width:0;height:0;
	border-left:4px solid rgba(0,0,0,0.5);border-top:4px solid transparent;border-bottom:4px solid transparent }


</style>
<!-- /Dropdown Menu Widget Styles -->

 <style type="text/css" id="custom-background-css">
body.custom-background { background-color: #dbdbdb; }
</style>
<!-- Google Analytics Tracking by Google Analyticator 6.5.4: http://www.videousermanuals.com/google-analyticator/ -->
<script type="text/javascript">
    var analyticsFileTypes = [''];
    var analyticsSnippet = 'disabled';
    var analyticsEventTracking = 'enabled';
</script>
<script type="text/javascript">
	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
	ga('create', 'UA-47237561-1', 'auto');
	ga('require', 'displayfeatures');
 
	ga('send', 'pageview');
	<!-- Enabling Google Analytics Social Tracking code Starts Here -->

<!-- Enabling Google Analytics Social Tracking code Ends Here -->
</script>
</head>
<body class="post-template-default single single-post postid-43967 single-format-standard custom-background custom-header header-image content-sidebar"><div id="wrap"><div id="nav"><div class="wrap"><ul id="menu-top" class="menu genesis-nav-menu menu-primary"><li id="menu-item-2067" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2067"><a href="http://thewichitan.com/contact/">Contact</a></li>
<li id="menu-item-2217" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2217"><a href="http://thewichitan.com/classifieds/">Classifieds</a></li>
<li id="menu-item-2336" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2336"><a href="http://thewichitan.com/advertising/">Advertising</a></li>
<li id="menu-item-2066" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2066"><a href="http://thewichitan.com/archives/">Archives</a></li>
<li id="menu-item-30970" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30970"><a title="Meet the Staff" href="http://thewichitan.com/staffers/">Meet the Staff</a></li>
<li id="menu-item-15538" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15538"><a href="http://thewichitan.com/work-with-us/">Work with us</a></li>
<li id="menu-item-15547" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15547"><a href="http://thewichitan.com/wichitan-job-descriptions/">Wichitan Job Descriptions</a></li>
<li id="menu-item-15548" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15548"><a href="http://thewichitan.com/wichitan-policies/">Wichitan Policies</a></li>
<li class="right date">October 20, 2017</li></ul></div></div><div id="header"><div class="wrap"><div id="title-area"><p id="title"><a href="http://thewichitan.com/">The Wichitan</a></p><p id="description">Your Campus - Your News</p></div><div class="widget-area header-widget-area"><div id="search-3" class="widget widget_search"><div class="widget-wrap"><form method="get" class="searchform search-form" action="http://thewichitan.com/" role="search" ><input type="text" value="Search this website &#x2026;" name="s" class="s search-input" onfocus="if (&#039;Search this website &#x2026;&#039; === this.value) {this.value = &#039;&#039;;}" onblur="if (&#039;&#039; === this.value) {this.value = &#039;Search this website &#x2026;&#039;;}" /><input type="submit" class="searchsubmit search-submit" value="Search" /></form></div></div>
</div></div></div><div id="subnav"><div class="wrap"><ul id="menu-normal" class="menu genesis-nav-menu menu-secondary"><li id="menu-item-317" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-317"><a href="http://thewichitan.com/">Home</a></li>
<li id="menu-item-306" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-306"><a href="http://thewichitan.com/category/news/">News</a>
<ul  class="sub-menu">
	<li id="menu-item-307" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-307"><a href="http://thewichitan.com/category/news/campus/">Campus</a></li>
	<li id="menu-item-308" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-308"><a href="http://thewichitan.com/category/news/local/">Local</a></li>
</ul>
</li>
<li id="menu-item-310" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-310"><a href="http://thewichitan.com/category/op-ed/">Campus Voice</a>
<ul  class="sub-menu">
	<li id="menu-item-312" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-312"><a href="http://thewichitan.com/category/op-ed/staff-editorial/">Staff Editorial</a></li>
	<li id="menu-item-4218" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4218"><a href="http://thewichitan.com/category/op-ed/letters-to-the-editor/">Letters to the Editor</a></li>
</ul>
</li>
<li id="menu-item-303" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-303"><a href="http://thewichitan.com/category/ae/">Entertainment</a></li>
<li id="menu-item-315" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-315"><a href="http://thewichitan.com/category/sports/">Sports</a></li>
<li id="menu-item-2070" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-2070"><a href="http://thewichitan.com/category/webexclusive/">Web Exclusives</a>
<ul  class="sub-menu">
	<li id="menu-item-19396" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19396"><a href="http://thewichitan.com/publicity-planning/">Publicity planning</a></li>
	<li id="menu-item-17633" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17633"><a href="http://thewichitan.com/category/webexclusive/presidentialponderings/">Presidential Ponderings</a></li>
</ul>
</li>
</ul></div></div><div class="breadcrumb" itemscope itemtype="https://schema.org/BreadcrumbList">You are here: <a href="http://thewichitan.com/"><span>Home</span></a> <span aria-label="breadcrumb separator">/</span> <a href="http://thewichitan.com/category/news/"><span>News</span></a> <span aria-label="breadcrumb separator">/</span> 450 flames light torch parade</div><div id="inner"><div id="content-sidebar-wrap"><div id="content" class="hfeed"><div class="post-43967 post type-post status-publish format-standard has-post-thumbnail hentry category-campus category-news tag-bonfire tag-homecoming tag-lip-sync tag-midwestern-state tag-torches tag-torchlight-parade entry"><h1 class="entry-title">450 flames light torch parade</h1>
<div class="post-info"><span class="date published time" title="2017-10-20T10:36:37+00:00">October 20, 2017</span>  by <span class="author vcard"><span class="fn"><a href="http://thewichitan.com/author/dfield/" rel="author">Devin Field</a></span></span> <span class="post-comments"><a href="http://thewichitan.com/450-flames-light-torch-parade/#respond">Leave a Comment</a></span> </div><div class="entry-content"><div id="attachment_44024" style="width: 610px" class="wp-caption aligncenter"><img class="size-large wp-image-44024" src="http://thewichitan.com/wp-content/uploads/2017/10/flames_004-1024x747.jpg" alt="" width="600" height="438" srcset="http://thewichitan.com/wp-content/uploads/2017/10/flames_004.jpg 1024w, http://thewichitan.com/wp-content/uploads/2017/10/flames_004-300x219.jpg 300w, http://thewichitan.com/wp-content/uploads/2017/10/flames_004-768x560.jpg 768w" sizes="(max-width: 600px) 100vw, 600px" /><p class="wp-caption-text">Anthony Onwuegbuchu, mechanical engineering junior, at the homecoming torchlight parade, Oct. 19. Photo by Sara Keeling</p></div>
<p>Campus streets radiated with the warm light of 450 torches held by students as they marched toward the bonfire. Students, faculty and staff alike took part in the torchlight parade leading to the homecoming events Oct. 19. Student organizations took part in presenting the final round of the lip-sync competition, where Alpha Psi Omega, the cheerleaders and the Caribbean Student Organization battled for the victory. Results of the competition will be announced at the football game against West Texas A&amp;M on Saturday, Oct. 21.</p>
<p>Ruby Arriaga, activities coordinator, led the parade, clapping and smiling as torches lit up behind her.</p>
<p>&#8220;This is the first time that I was in the front making sure everything was great instead of rushing over here with the trash cans,&#8221; Arriaga said. &#8220;It looked like a lot of students were having fun, they were cheering with the band and cheering with the cheerleaders so it went really well.&#8221;</p>
<p>Members of the University Programming Board had 500 torches to be handed out for the parade, 100 fewer than last year.</p>
<p>&#8220;I just wanna be apart of all the traditions they have here,&#8221; Sierra Martinez, early childhood education freshman, said. &#8220;I&#8217;ve never heard of a torchlight parade before and never been apart of one. Just the fact that we all come together as one instead of dividing among the campus I think that&#8217;s really unique and good.&#8221;</p>
<p>Students were dancing through the streets, torches in hand, showing their school spirit.</p>
<p>&#8220;This is my fourth year in college, and my fourth year coming out to this,&#8221; Kaleb Akona, mechanical engineering, said. &#8220;It looks like 300 people are out here and their torches light up the whole place up and it&#8217;s cool. This is a week where we have more school spirit and people from all organizations come out, you get to see all new people and a lot of fire.&#8221;</p>
<h3>More quotes from students</h3>
<ul>
<li>&#8220;It&#8217;s lit. It&#8217;s always lit. I love the tradition of the torchlight parade because everyone is so hyped up and ready to party. I can&#8217;t lie, this city is dusty, but homecoming is when this campus comes to life.&#8221; <strong>&#8211; Jaylon Williams, economics and sociology senior.</strong></li>
<li>&#8220;I love holding fire. The bonfire is amazing, but getting to march with the rest of the students is the best part.&#8221; <strong>&#8211; Lia Wiley, radiology sophomore.</strong></li>
<li>&#8220;Walking toward the big stack of pallets with the band, the students and cheerleaders is just great. I have loved carrying the torch in the past and I love doing it now. I&#8217;ve kept up with the lip sync thus far, and am so excited to see the final round.&#8221; <strong>&#8211; Lupe Munoz, nursing sophomore.</strong></li>
<li>&#8220;I&#8217;m especially excited because today is my birthday. I&#8217;m 22, and I&#8217;m happy to spend part of my night here with my fellow Mustangs. Every year, the torchlight parade gets better and better. My freshman year I just participated, but every year since I&#8217;ve been able to help coordinate the event with the Residence Hall Association. It&#8217;s my last bonfire. I traded my other college T-shirt and I&#8217;m ready to watch it burn.&#8221; <strong>&#8211; Ashley Ates, global studies senior.</strong></li>
<li>&#8220;Homecoming is always great because you get to see the students realize that Midwestern really is a second home. These kinds of events create a campus pride. It really is funny because I actually went to college in the 90s and things are a lot different. It&#8217;s nice.&#8221; <strong>&#8211; Kristi Schulte, director of residence life and housing.</strong></li>
<li>&#8220;The bonfire is cool until it melts your face off. It gets so hot so fast, and you can feel the flames from the street. As for homecoming as a whole, so far so good. I&#8217;ve liked the events, but I could have sworn we had more torches in the past. We have a lot more students than we do torches.&#8221; <strong>&#8211; Addison Kassady, management sophomore.</strong></li>
</ul>
<p><em>Additional reporting by Brendan Wynne</em></p>
<p style="text-align: center;"><div class="flagallery phantom_skin" id="FlaGallery_sc1_161" style='width:1024;'><style type="text/css" class="flagallery_skin_style_import">#FlaGallery_sc1_161 .flagPhantom_ThumbContainer {width:200px; height:180px;}#FlaGallery_sc1_161 .flagPhantom_MobileView .flagPhantom_ThumbContainer {width:150px; height:135px;}#FlaGallery_sc1_161 .flagPhantom_Container {margin-left:auto;margin-right:auto;}#FlaGallery_sc1_161 .flagPhantom_ThumbContainer {margin:8px 0 0 8px;}#FlaGallery_sc1_161 .flagPhantom_ThumbContainer {padding:2px;}#FlaGallery_sc1_161 .flagPhantom_LabelBottom .flagPhantom_ThumbContainer {padding-bottom:36px;}#FlaGallery_sc1_161 .flagPhantom_ThumbContainer,#FlaGallery_sc1_161 .flagPhantom_LabelBottom .flagPhantom_ThumbLabel {background-color:#ffffff;}#FlaGallery_sc1_161 .flagPhantom_ThumbContainer .flagPhantom_Thumb {opacity:0.9;}#FlaGallery_sc1_161 .flagPhantom_ThumbContainer:hover .flagPhantom_Thumb {opacity:1;}#FlaGallery_sc1_161 .flagPhantom_ThumbContainer {border:1px solid #cccccc;}#FlaGallery_sc1_161 .flagPhantom_ThumbContainer {box-shadow:0 0 5px -2px #cccccc;}#FlaGallery_sc1_161 .flagPhantom_ThumbLabel {color:#0b0b0b;}#FlaGallery_sc1_161 .flagPhantom_ThumbLabel a {color:#3695E7;}#FlaGallery_sc1_161 .flagPhantom_LabelInside .flagPhantom_ThumbLabel,#FlaGallery_sc1_161 .flagPhantom_LabelHover .flagPhantom_ThumbLabel {color:#ffffff;}#FlaGallery_sc1_161 .flagPhantom_LabelInside .flagPhantom_ThumbLabel a,#FlaGallery_sc1_161 .flagPhantom_LabelHover .flagPhantom_ThumbLabel a,#FlaGallery_sc1_161 .flagPhantom_LabelInside .flagPhantom_ThumbLabel a:hover,#FlaGallery_sc1_161 .flagPhantom_LabelHover .flagPhantom_ThumbLabel a:hover {color:#e7e179;}</style> <div class="flagPhantom_Container noLightbox" style="opacity:0"> <h3>flames2017</h3> <div class="flagPhantom_thumbsWrapper flagPhantom_ThumbScale flagPhantom_LabelHover"> <div class="flagPhantom_ThumbContainer flagPhantom_ThumbLoader" data-id="2559" data-ratio="1.43417366947" data-title="Trey Honea, Criminal Justice Sophmore, ends the torch light parade by blowing out his torch as he and his friends make their way towards the bonfire, Thursday, Oct 19,2017. Photo by Sara Keeling" data-views="0" data-likes="0" data-download="http://thewichitan.com/wp-content/flagallery/flames2017/flames_001.jpg" data-filename="flames_001.jpg"> <a href="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_001.jpg" class="flagPhantom_Thumb"><img src="http://thewichitan.com/wp-content/flagallery/flames2017/thumbs/thumbs_flames_001.jpg" data-src="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_001.jpg" alt="Trey Honea, Criminal Justice Sophmore, ends the torch light parade by blowing out his torch as he and his friends make their way towards the bonfire, Thursday, Oct 19,2017. Photo by Sara Keeling"/></a> <div class="flagPhantom_ThumbLabel"> <span class="flagPhantom_ThumbLabel_title">Trey Honea, Criminal Justice Sophmore, ends the torch light parade by blowing out his torch as he and his friends make their way towards the bonfire, Thursday, Oct 19,2017. Photo by Sara Keeling</span></div> <div style="display:none;" class="flagPhantom_Details"> <div class="flagPhantom_description"> <div class="flagPhantom_title">Trey Honea, Criminal Justice Sophmore, ends the torch light parade by blowing out his torch as he and his friends make their way towards the bonfire, Thursday, Oct 19,2017. Photo by Sara Keeling</div> <div class="flagPhantom_text"><p>Trey Honea, Criminal Justice Sophmore, ends the torch light parade by blowing out his torch as he and his friends make their way towards the bonfire, Thursday, Oct 19,2017. Photo by Sara Keeling</p></div> </div> </div> </div> <div class="flagPhantom_ThumbContainer flagPhantom_ThumbLoader" data-id="2534" data-ratio="1" data-title="Keelie Ralston, kinesiology junior, and Alicia Mayhugh, kinesiology junior, get ready to start the torchlight parade at MSU on Thursday, Oct. 19, 2017. Photo by Harlie David" data-views="0" data-likes="0" data-download="http://thewichitan.com/wp-content/flagallery/flames2017/flames_002.jpg" data-filename="flames_002.jpg"> <a href="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_002.jpg" class="flagPhantom_Thumb"><img src="http://thewichitan.com/wp-content/flagallery/flames2017/thumbs/thumbs_flames_002.jpg" data-src="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_002.jpg" alt="Keelie Ralston, kinesiology junior, and Alicia Mayhugh, kinesiology junior, get ready to start the torchlight parade at MSU on Thursday, Oct. 19, 2017. Photo by Harlie David"/></a> <div class="flagPhantom_ThumbLabel"> <span class="flagPhantom_ThumbLabel_title">Keelie Ralston, kinesiology junior, and Alicia Mayhugh, kinesiology junior, get ready to start the torchlight parade at MSU on Thursday, Oct. 19, 2017. Photo by Harlie David</span></div> <div style="display:none;" class="flagPhantom_Details"> <div class="flagPhantom_description"> <div class="flagPhantom_title">Keelie Ralston, kinesiology junior, and Alicia Mayhugh, kinesiology junior, get ready to start the torchlight parade at MSU on Thursday, Oct. 19, 2017. Photo by Harlie David</div> <div class="flagPhantom_text"><p>Keelie Ralston, kinesiology junior, and Alicia Mayhugh, kinesiology junior, get ready to start the torchlight parade at MSU on Thursday, Oct. 19, 2017. Photo by Harlie David</p></div> </div> </div> </div> <div class="flagPhantom_ThumbContainer flagPhantom_ThumbLoader" data-id="2535" data-ratio="1" data-title="Autumn Duval, early childhood education freshman, enjoys the torchlight parade at MSU on Thursday, Oct. 19, 2017. Photo by Harlie David" data-views="0" data-likes="0" data-download="http://thewichitan.com/wp-content/flagallery/flames2017/flames_003.jpg" data-filename="flames_003.jpg"> <a href="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_003.jpg" class="flagPhantom_Thumb"><img src="http://thewichitan.com/wp-content/flagallery/flames2017/thumbs/thumbs_flames_003.jpg" data-src="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_003.jpg" alt="Autumn Duval, early childhood education freshman, enjoys the torchlight parade at MSU on Thursday, Oct. 19, 2017. Photo by Harlie David"/></a> <div class="flagPhantom_ThumbLabel"> <span class="flagPhantom_ThumbLabel_title">Autumn Duval, early childhood education freshman, enjoys the torchlight parade at MSU on Thursday, Oct. 19, 2017. Photo by Harlie David</span></div> <div style="display:none;" class="flagPhantom_Details"> <div class="flagPhantom_description"> <div class="flagPhantom_title">Autumn Duval, early childhood education freshman, enjoys the torchlight parade at MSU on Thursday, Oct. 19, 2017. Photo by Harlie David</div> <div class="flagPhantom_text"><p>Autumn Duval, early childhood education freshman, enjoys the torchlight parade at MSU on Thursday, Oct. 19, 2017. Photo by Harlie David</p></div> </div> </div> </div> <div class="flagPhantom_ThumbContainer flagPhantom_ThumbLoader" data-id="2536" data-ratio="1.37081659973" data-title="Anthony Onwuegbuchu, mechinical enginering junior , at the homecoming torch light parade, Thurday , Oct 19,2017. Photo by Sara Keeling" data-views="1" data-likes="0" data-download="http://thewichitan.com/wp-content/flagallery/flames2017/flames_004.jpg" data-filename="flames_004.jpg"> <a href="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_004.jpg" class="flagPhantom_Thumb"><img src="http://thewichitan.com/wp-content/flagallery/flames2017/thumbs/thumbs_flames_004.jpg" data-src="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_004.jpg" alt="Anthony Onwuegbuchu, mechinical enginering junior , at the homecoming torch light parade, Thurday , Oct 19,2017. Photo by Sara Keeling"/></a> <div class="flagPhantom_ThumbLabel"> <span class="flagPhantom_ThumbLabel_title">Anthony Onwuegbuchu, mechinical enginering junior , at the homecoming torch light parade, Thurday , Oct 19,2017. Photo by Sara Keeling</span></div> <div style="display:none;" class="flagPhantom_Details"> <div class="flagPhantom_description"> <div class="flagPhantom_title">Anthony Onwuegbuchu, mechinical enginering junior , at the homecoming torch light parade, Thurday , Oct 19,2017. Photo by Sara Keeling</div> <div class="flagPhantom_text"><p>Anthony Onwuegbuchu, mechinical enginering junior , at the homecoming torch light parade, Thurday , Oct 19,2017. Photo by Sara Keeling</p></div> </div> </div> </div> <div class="flagPhantom_ThumbContainer flagPhantom_ThumbLoader" data-id="2537" data-ratio="1.49926793558" data-title="Scydayah Quest, sociology junior, and Denaijah Shaw, athletic training junior at the torch lighting. Oct. 19, 2017. Elias Maki" data-views="1" data-likes="0" data-download="http://thewichitan.com/wp-content/flagallery/flames2017/flames_005.jpg" data-filename="flames_005.jpg"> <a href="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_005.jpg" class="flagPhantom_Thumb"><img src="http://thewichitan.com/wp-content/flagallery/flames2017/thumbs/thumbs_flames_005.jpg" data-src="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_005.jpg" alt="Scydayah Quest, sociology junior, and Denaijah Shaw, athletic training junior at the torch lighting. Oct. 19, 2017. Elias Maki"/></a> <div class="flagPhantom_ThumbLabel"> <span class="flagPhantom_ThumbLabel_title">Scydayah Quest, sociology junior, and Denaijah Shaw, athletic training junior at the torch lighting. Oct. 19, 2017. Elias Maki</span></div> <div style="display:none;" class="flagPhantom_Details"> <div class="flagPhantom_description"> <div class="flagPhantom_title">Scydayah Quest, sociology junior, and Denaijah Shaw, athletic training junior at the torch lighting. Oct. 19, 2017. Elias Maki</div> <div class="flagPhantom_text"><p>Scydayah Quest, sociology junior, and Denaijah Shaw, athletic training junior at the torch lighting. Oct. 19, 2017. Elias Maki</p></div> </div> </div> </div> <div class="flagPhantom_ThumbContainer flagPhantom_ThumbLoader" data-id="2538" data-ratio="1.32987012987" data-title="Keanna Jenkins, buisiness freshman, and Isaac Liguez, dental hygiene freshman at the torch lighting. 19th October 2017. Photo by Elias Maki" data-views="1" data-likes="0" data-download="http://thewichitan.com/wp-content/flagallery/flames2017/flames_006.jpg" data-filename="flames_006.jpg"> <a href="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_006.jpg" class="flagPhantom_Thumb"><img src="http://thewichitan.com/wp-content/flagallery/flames2017/thumbs/thumbs_flames_006.jpg" data-src="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_006.jpg" alt="Keanna Jenkins, buisiness freshman, and Isaac Liguez, dental hygiene freshman at the torch lighting. 19th October 2017. Photo by Elias Maki"/></a> <div class="flagPhantom_ThumbLabel"> <span class="flagPhantom_ThumbLabel_title">Keanna Jenkins, buisiness freshman, and Isaac Liguez, dental hygiene freshman at the torch lighting. 19th October 2017. Photo by Elias Maki</span></div> <div style="display:none;" class="flagPhantom_Details"> <div class="flagPhantom_description"> <div class="flagPhantom_title">Keanna Jenkins, buisiness freshman, and Isaac Liguez, dental hygiene freshman at the torch lighting. 19th October 2017. Photo by Elias Maki</div> <div class="flagPhantom_text"><p>Keanna Jenkins, buisiness freshman, and Isaac Liguez, dental hygiene freshman at the torch lighting. 19th October 2017. Photo by Elias Maki</p></div> </div> </div> </div> <div class="flagPhantom_ThumbContainer flagPhantom_ThumbLoader" data-id="2539" data-ratio="1" data-title="Conney Vargas, marketing senior, holds her hand infront of the flame as she walks towards to front of the parade being one of the first to get her torch lit at the Torchlight Parade tradition apart of MSU Homecoming, Thursday, Oct. 19, 2017. Photo by Rachel Johnson" data-views="1" data-likes="0" data-download="http://thewichitan.com/wp-content/flagallery/flames2017/flames_007.jpg" data-filename="flames_007.jpg"> <a href="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_007.jpg" class="flagPhantom_Thumb"><img src="http://thewichitan.com/wp-content/flagallery/flames2017/thumbs/thumbs_flames_007.jpg" data-src="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_007.jpg" alt="Conney Vargas, marketing senior, holds her hand infront of the flame as she walks towards to front of the parade being one of the first to get her torch lit at the Torchlight Parade tradition apart of MSU Homecoming, Thursday, Oct. 19, 2017. Photo by Rachel Johnson"/></a> <div class="flagPhantom_ThumbLabel"> <span class="flagPhantom_ThumbLabel_title">Conney Vargas, marketing senior, holds her hand infront of the flame as she walks towards to front of the parade being one of the first to get her torch lit at the Torchlight Parade tradition apart of MSU Homecoming, Thursday, Oct. 19, 2017. Photo by Rachel Johnson</span></div> <div style="display:none;" class="flagPhantom_Details"> <div class="flagPhantom_description"> <div class="flagPhantom_title">Conney Vargas, marketing senior, holds her hand infront of the flame as she walks towards to front of the parade being one of the first to get her torch lit at the Torchlight Parade tradition apart of MSU Homecoming, Thursday, Oct. 19, 2017. Photo by Rachel Johnson</div> <div class="flagPhantom_text"><p>Conney Vargas, marketing senior, holds her hand infront of the flame as she walks towards to front of the parade being one of the first to get her torch lit at the Torchlight Parade tradition apart of MSU Homecoming, Thursday, Oct. 19, 2017. Photo by Rachel Johnson</p></div> </div> </div> </div> <div class="flagPhantom_ThumbContainer flagPhantom_ThumbLoader" data-id="2540" data-ratio="1.49926793558" data-title="Joshua Luffman, psychology sophomore, and Courtney Lawrence, dental hygiene sophomore, walk in the torch parade. Photo by Bradley Wilson" data-views="1" data-likes="0" data-download="http://thewichitan.com/wp-content/flagallery/flames2017/flames_008.jpg" data-filename="flames_008.jpg"> <a href="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_008.jpg" class="flagPhantom_Thumb"><img src="http://thewichitan.com/wp-content/flagallery/flames2017/thumbs/thumbs_flames_008.jpg" data-src="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_008.jpg" alt="Joshua Luffman, psychology sophomore, and Courtney Lawrence, dental hygiene sophomore, walk in the torch parade. Photo by Bradley Wilson"/></a> <div class="flagPhantom_ThumbLabel"> <span class="flagPhantom_ThumbLabel_title">Joshua Luffman, psychology sophomore, and Courtney Lawrence, dental hygiene sophomore, walk in the torch parade. Photo by Bradley Wilson</span></div> <div style="display:none;" class="flagPhantom_Details"> <div class="flagPhantom_description"> <div class="flagPhantom_title">Joshua Luffman, psychology sophomore, and Courtney Lawrence, dental hygiene sophomore, walk in the torch parade. Photo by Bradley Wilson</div> <div class="flagPhantom_text"><p>Joshua Luffman, psychology sophomore, and Courtney Lawrence, dental hygiene sophomore, walk in the torch parade. Photo by Bradley Wilson</p></div> </div> </div> </div> <div class="flagPhantom_ThumbContainer flagPhantom_ThumbLoader" data-id="2541" data-ratio="1" data-title="Kimrie Brock, junior, and Kaitlynn Briant, nursing sophomore at the bonfire. 19th October 2017. Elias Maki" data-views="1" data-likes="0" data-download="http://thewichitan.com/wp-content/flagallery/flames2017/flames_009.jpg" data-filename="flames_009.jpg"> <a href="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_009.jpg" class="flagPhantom_Thumb"><img src="http://thewichitan.com/wp-content/flagallery/flames2017/thumbs/thumbs_flames_009.jpg" data-src="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_009.jpg" alt="Kimrie Brock, junior, and Kaitlynn Briant, nursing sophomore at the bonfire. 19th October 2017. Elias Maki"/></a> <div class="flagPhantom_ThumbLabel"> <span class="flagPhantom_ThumbLabel_title">Kimrie Brock, junior, and Kaitlynn Briant, nursing sophomore at the bonfire. 19th October 2017. Elias Maki</span></div> <div style="display:none;" class="flagPhantom_Details"> <div class="flagPhantom_description"> <div class="flagPhantom_title">Kimrie Brock, junior, and Kaitlynn Briant, nursing sophomore at the bonfire. 19th October 2017. Elias Maki</div> <div class="flagPhantom_text"><p>Kimrie Brock, junior, and Kaitlynn Briant, nursing sophomore at the bonfire. 19th October 2017. Elias Maki</p></div> </div> </div> </div> <div class="flagPhantom_ThumbContainer flagPhantom_ThumbLoader" data-id="2542" data-ratio="1.49926793558" data-title="Matt Graham, sophomore in mechanical engineering, and Lia Wiley, radiology sophomore, walk in the torchlight parade. Photo by Bradley Wilson" data-views="2" data-likes="0" data-download="http://thewichitan.com/wp-content/flagallery/flames2017/flames_010.jpg" data-filename="flames_010.jpg"> <a href="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_010.jpg" class="flagPhantom_Thumb"><img src="http://thewichitan.com/wp-content/flagallery/flames2017/thumbs/thumbs_flames_010.jpg" data-src="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_010.jpg" alt="Matt Graham, sophomore in mechanical engineering, and Lia Wiley, radiology sophomore, walk in the torchlight parade. Photo by Bradley Wilson"/></a> <div class="flagPhantom_ThumbLabel"> <span class="flagPhantom_ThumbLabel_title">Matt Graham, sophomore in mechanical engineering, and Lia Wiley, radiology sophomore, walk in the torchlight parade. Photo by Bradley Wilson</span></div> <div style="display:none;" class="flagPhantom_Details"> <div class="flagPhantom_description"> <div class="flagPhantom_title">Matt Graham, sophomore in mechanical engineering, and Lia Wiley, radiology sophomore, walk in the torchlight parade. Photo by Bradley Wilson</div> <div class="flagPhantom_text"><p>Matt Graham, sophomore in mechanical engineering, and Lia Wiley, radiology sophomore, walk in the torchlight parade. Photo by Bradley Wilson</p></div> </div> </div> </div> <div class="flagPhantom_ThumbContainer flagPhantom_ThumbLoader" data-id="2543" data-ratio="1.25798525799" data-title="Bill Maskill, MSU head football coach, walks through the crowd with a tiki torch to begin the MSU Bonfire, Thursday, Oct. 19, 2017. Photo by Francisco Martinez" data-views="1" data-likes="0" data-download="http://thewichitan.com/wp-content/flagallery/flames2017/flames_011.jpg" data-filename="flames_011.jpg"> <a href="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_011.jpg" class="flagPhantom_Thumb"><img src="http://thewichitan.com/wp-content/flagallery/flames2017/thumbs/thumbs_flames_011.jpg" data-src="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_011.jpg" alt="Bill Maskill, MSU head football coach, walks through the crowd with a tiki torch to begin the MSU Bonfire, Thursday, Oct. 19, 2017. Photo by Francisco Martinez"/></a> <div class="flagPhantom_ThumbLabel"> <span class="flagPhantom_ThumbLabel_title">Bill Maskill, MSU head football coach, walks through the crowd with a tiki torch to begin the MSU Bonfire, Thursday, Oct. 19, 2017. Photo by Francisco Martinez</span></div> <div style="display:none;" class="flagPhantom_Details"> <div class="flagPhantom_description"> <div class="flagPhantom_title">Bill Maskill, MSU head football coach, walks through the crowd with a tiki torch to begin the MSU Bonfire, Thursday, Oct. 19, 2017. Photo by Francisco Martinez</div> <div class="flagPhantom_text"><p>Bill Maskill, MSU head football coach, walks through the crowd with a tiki torch to begin the MSU Bonfire, Thursday, Oct. 19, 2017. Photo by Francisco Martinez</p></div> </div> </div> </div> <div class="flagPhantom_ThumbContainer flagPhantom_ThumbLoader" data-id="2544" data-ratio="1.3544973545" data-title="Addison Semer, mass communication senior, and Leah Lychock, exercise physiology senior, light the homecoming bonfire Oct. 19, 2017. Photo by Rachel Johnson" data-views="0" data-likes="0" data-download="http://thewichitan.com/wp-content/flagallery/flames2017/flames_012.jpg" data-filename="flames_012.jpg"> <a href="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_012.jpg" class="flagPhantom_Thumb"><img src="http://thewichitan.com/wp-content/flagallery/flames2017/thumbs/thumbs_flames_012.jpg" data-src="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_012.jpg" alt="Addison Semer, mass communication senior, and Leah Lychock, exercise physiology senior, light the homecoming bonfire Oct. 19, 2017. Photo by Rachel Johnson"/></a> <div class="flagPhantom_ThumbLabel"> <span class="flagPhantom_ThumbLabel_title">Addison Semer, mass communication senior, and Leah Lychock, exercise physiology senior, light the homecoming bonfire Oct. 19, 2017. Photo by Rachel Johnson</span></div> <div style="display:none;" class="flagPhantom_Details"> <div class="flagPhantom_description"> <div class="flagPhantom_title">Addison Semer, mass communication senior, and Leah Lychock, exercise physiology senior, light the homecoming bonfire Oct. 19, 2017. Photo by Rachel Johnson</div> <div class="flagPhantom_text"><p>Addison Semer, mass communication senior, and Leah Lychock, exercise physiology senior, light the homecoming bonfire Oct. 19, 2017. Photo by Rachel Johnson</p></div> </div> </div> </div> <div class="flagPhantom_ThumbContainer flagPhantom_ThumbLoader" data-id="2545" data-ratio="1.49053857351" data-title="Head Volleyball Coach Natalie Burton lights the Homecoming Bonfire Thursday, Oct. 19, 2017. Photo by Rachel Johsnon" data-views="0" data-likes="0" data-download="http://thewichitan.com/wp-content/flagallery/flames2017/flames_013.jpg" data-filename="flames_013.jpg"> <a href="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_013.jpg" class="flagPhantom_Thumb"><img src="http://thewichitan.com/wp-content/flagallery/flames2017/thumbs/thumbs_flames_013.jpg" data-src="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_013.jpg" alt="Head Volleyball Coach Natalie Burton lights the Homecoming Bonfire Thursday, Oct. 19, 2017. Photo by Rachel Johsnon"/></a> <div class="flagPhantom_ThumbLabel"> <span class="flagPhantom_ThumbLabel_title">Head Volleyball Coach Natalie Burton lights the Homecoming Bonfire Thursday, Oct. 19, 2017. Photo by Rachel Johsnon</span></div> <div style="display:none;" class="flagPhantom_Details"> <div class="flagPhantom_description"> <div class="flagPhantom_title">Head Volleyball Coach Natalie Burton lights the Homecoming Bonfire Thursday, Oct. 19, 2017. Photo by Rachel Johsnon</div> <div class="flagPhantom_text"><p>Head Volleyball Coach Natalie Burton lights the Homecoming Bonfire Thursday, Oct. 19, 2017. Photo by Rachel Johsnon</p></div> </div> </div> </div> <div class="flagPhantom_ThumbContainer flagPhantom_ThumbLoader" data-id="2546" data-ratio="1.26889714994" data-title="Mario Ramirez, interim director of student involvement, at the homecoming bonfire Oct. 19, 2017. Photo by Bradley Wilson" data-views="0" data-likes="0" data-download="http://thewichitan.com/wp-content/flagallery/flames2017/flames_014.jpg" data-filename="flames_014.jpg"> <a href="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_014.jpg" class="flagPhantom_Thumb"><img src="http://thewichitan.com/wp-content/flagallery/flames2017/thumbs/thumbs_flames_014.jpg" data-src="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_014.jpg" alt="Mario Ramirez, interim director of student involvement, at the homecoming bonfire Oct. 19, 2017. Photo by Bradley Wilson"/></a> <div class="flagPhantom_ThumbLabel"> <span class="flagPhantom_ThumbLabel_title">Mario Ramirez, interim director of student involvement, at the homecoming bonfire Oct. 19, 2017. Photo by Bradley Wilson</span></div> <div style="display:none;" class="flagPhantom_Details"> <div class="flagPhantom_description"> <div class="flagPhantom_title">Mario Ramirez, interim director of student involvement, at the homecoming bonfire Oct. 19, 2017. Photo by Bradley Wilson</div> <div class="flagPhantom_text"><p>Mario Ramirez, interim director of student involvement, at the homecoming bonfire Oct. 19, 2017. Photo by Bradley Wilson</p></div> </div> </div> </div> <div class="flagPhantom_ThumbContainer flagPhantom_ThumbLoader" data-id="2547" data-ratio="1.40852819807" data-title="Joshua Luffman, psychology sophomore, and Courtney Lawrence, dental hygiene, share a kiss during the MSU Pep Rally &amp; Bonfire at Nocona Trail South Lot, Thursday, Oct. 19, 2017. Photo by Francisco Martinez" data-views="0" data-likes="0" data-download="http://thewichitan.com/wp-content/flagallery/flames2017/flames_015.jpg" data-filename="flames_015.jpg"> <a href="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_015.jpg" class="flagPhantom_Thumb"><img src="http://thewichitan.com/wp-content/flagallery/flames2017/thumbs/thumbs_flames_015.jpg" data-src="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_015.jpg" alt="Joshua Luffman, psychology sophomore, and Courtney Lawrence, dental hygiene, share a kiss during the MSU Pep Rally &amp; Bonfire at Nocona Trail South Lot, Thursday, Oct. 19, 2017. Photo by Francisco Martinez"/></a> <div class="flagPhantom_ThumbLabel"> <span class="flagPhantom_ThumbLabel_title">Joshua Luffman, psychology sophomore, and Courtney Lawrence, dental hygiene, share a kiss during the MSU Pep Rally & Bonfire at Nocona Trail South Lot, Thursday, Oct. 19, 2017. Photo by Francisco Martinez</span></div> <div style="display:none;" class="flagPhantom_Details"> <div class="flagPhantom_description"> <div class="flagPhantom_title">Joshua Luffman, psychology sophomore, and Courtney Lawrence, dental hygiene, share a kiss during the MSU Pep Rally & Bonfire at Nocona Trail South Lot, Thursday, Oct. 19, 2017. Photo by Francisco Martinez</div> <div class="flagPhantom_text"><p>Joshua Luffman, psychology sophomore, and Courtney Lawrence, dental hygiene, share a kiss during the MSU Pep Rally & Bonfire at Nocona Trail South Lot, Thursday, Oct. 19, 2017. Photo by Francisco Martinez</p></div> </div> </div> </div> <div class="flagPhantom_ThumbContainer flagPhantom_ThumbLoader" data-id="2548" data-ratio="1.49926793558" data-title="" data-views="0" data-likes="0" data-download="http://thewichitan.com/wp-content/flagallery/flames2017/flames_016.jpg" data-filename="flames_016.jpg"> <a href="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_016.jpg" class="flagPhantom_Thumb"><img src="http://thewichitan.com/wp-content/flagallery/flames2017/thumbs/thumbs_flames_016.jpg" data-src="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_016.jpg" alt=""/></a> <div class="flagPhantom_ThumbLabel"> <span class="flagPhantom_ThumbLabel_title"></span></div> <div style="display:none;" class="flagPhantom_Details"> </div> </div> <div class="flagPhantom_ThumbContainer flagPhantom_ThumbLoader" data-id="2549" data-ratio="1.49926793558" data-title="Head football coach Bill Maskill lights the bonfire on Oct. 27. Photo by Izziel Latour" data-views="0" data-likes="0" data-download="http://thewichitan.com/wp-content/flagallery/flames2017/flames_017.jpg" data-filename="flames_017.jpg"> <a href="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_017.jpg" class="flagPhantom_Thumb"><img src="http://thewichitan.com/wp-content/flagallery/flames2017/thumbs/thumbs_flames_017.jpg" data-src="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_017.jpg" alt="Head football coach Bill Maskill lights the bonfire on Oct. 27. Photo by Izziel Latour"/></a> <div class="flagPhantom_ThumbLabel"> <span class="flagPhantom_ThumbLabel_title">Head football coach Bill Maskill lights the bonfire on Oct. 27. Photo by Izziel Latour</span></div> <div style="display:none;" class="flagPhantom_Details"> <div class="flagPhantom_description"> <div class="flagPhantom_title">Head football coach Bill Maskill lights the bonfire on Oct. 27. Photo by Izziel Latour</div> <div class="flagPhantom_text"><p>Head football coach Bill Maskill lights the bonfire on Oct. 27. Photo by Izziel Latour</p></div> </div> </div> </div> <div class="flagPhantom_ThumbContainer flagPhantom_ThumbLoader" data-id="2550" data-ratio="1.49926793558" data-title="Joey McGinn, Jacob Turnbow and Seth Angelino at the homecoming bonfire Oct. 19, 2017. Photo by Bradley Wilson" data-views="0" data-likes="0" data-download="http://thewichitan.com/wp-content/flagallery/flames2017/flames_018.jpg" data-filename="flames_018.jpg"> <a href="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_018.jpg" class="flagPhantom_Thumb"><img src="http://thewichitan.com/wp-content/flagallery/flames2017/thumbs/thumbs_flames_018.jpg" data-src="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_018.jpg" alt="Joey McGinn, Jacob Turnbow and Seth Angelino at the homecoming bonfire Oct. 19, 2017. Photo by Bradley Wilson"/></a> <div class="flagPhantom_ThumbLabel"> <span class="flagPhantom_ThumbLabel_title">Joey McGinn, Jacob Turnbow and Seth Angelino at the homecoming bonfire Oct. 19, 2017. Photo by Bradley Wilson</span></div> <div style="display:none;" class="flagPhantom_Details"> <div class="flagPhantom_description"> <div class="flagPhantom_title">Joey McGinn, Jacob Turnbow and Seth Angelino at the homecoming bonfire Oct. 19, 2017. Photo by Bradley Wilson</div> <div class="flagPhantom_text"><p>Joey McGinn, Jacob Turnbow and Seth Angelino at the homecoming bonfire Oct. 19, 2017. Photo by Bradley Wilson</p></div> </div> </div> </div> <div class="flagPhantom_ThumbContainer flagPhantom_ThumbLoader" data-id="2551" data-ratio="1.3455978975" data-title="John Smith, psychology junior, gets a picture of the Homecoming Bonfire Thursday, Oct. 19, 2017. Photo by Rachel Johnson" data-views="0" data-likes="0" data-download="http://thewichitan.com/wp-content/flagallery/flames2017/flames_019.jpg" data-filename="flames_019.jpg"> <a href="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_019.jpg" class="flagPhantom_Thumb"><img src="http://thewichitan.com/wp-content/flagallery/flames2017/thumbs/thumbs_flames_019.jpg" data-src="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_019.jpg" alt="John Smith, psychology junior, gets a picture of the Homecoming Bonfire Thursday, Oct. 19, 2017. Photo by Rachel Johnson"/></a> <div class="flagPhantom_ThumbLabel"> <span class="flagPhantom_ThumbLabel_title">John Smith, psychology junior, gets a picture of the Homecoming Bonfire Thursday, Oct. 19, 2017. Photo by Rachel Johnson</span></div> <div style="display:none;" class="flagPhantom_Details"> <div class="flagPhantom_description"> <div class="flagPhantom_title">John Smith, psychology junior, gets a picture of the Homecoming Bonfire Thursday, Oct. 19, 2017. Photo by Rachel Johnson</div> <div class="flagPhantom_text"><p>John Smith, psychology junior, gets a picture of the Homecoming Bonfire Thursday, Oct. 19, 2017. Photo by Rachel Johnson</p></div> </div> </div> </div> <div class="flagPhantom_ThumbContainer flagPhantom_ThumbLoader" data-id="2552" data-ratio="1" data-title="Alexis Rucker, criminal justice sophomore, takes a picture her friends at the Homecoming Bonfire, Thursday, Oct. 19, 2017. Photo by Rachel Johnson" data-views="0" data-likes="0" data-download="http://thewichitan.com/wp-content/flagallery/flames2017/flames_020.jpg" data-filename="flames_020.jpg"> <a href="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_020.jpg" class="flagPhantom_Thumb"><img src="http://thewichitan.com/wp-content/flagallery/flames2017/thumbs/thumbs_flames_020.jpg" data-src="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_020.jpg" alt="Alexis Rucker, criminal justice sophomore, takes a picture her friends at the Homecoming Bonfire, Thursday, Oct. 19, 2017. Photo by Rachel Johnson"/></a> <div class="flagPhantom_ThumbLabel"> <span class="flagPhantom_ThumbLabel_title">Alexis Rucker, criminal justice sophomore, takes a picture her friends at the Homecoming Bonfire, Thursday, Oct. 19, 2017. Photo by Rachel Johnson</span></div> <div style="display:none;" class="flagPhantom_Details"> <div class="flagPhantom_description"> <div class="flagPhantom_title">Alexis Rucker, criminal justice sophomore, takes a picture her friends at the Homecoming Bonfire, Thursday, Oct. 19, 2017. Photo by Rachel Johnson</div> <div class="flagPhantom_text"><p>Alexis Rucker, criminal justice sophomore, takes a picture her friends at the Homecoming Bonfire, Thursday, Oct. 19, 2017. Photo by Rachel Johnson</p></div> </div> </div> </div> <div class="flagPhantom_ThumbContainer flagPhantom_ThumbLoader" data-id="2553" data-ratio="1.42420027816" data-title="Cameron O&#039;Neal, pre-med sophomore, gets a picture of the Homecoming Bonfire Thursday, Oct. 19, 2017. Photo by Rachel Johnson" data-views="0" data-likes="0" data-download="http://thewichitan.com/wp-content/flagallery/flames2017/flames_021.jpg" data-filename="flames_021.jpg"> <a href="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_021.jpg" class="flagPhantom_Thumb"><img src="http://thewichitan.com/wp-content/flagallery/flames2017/thumbs/thumbs_flames_021.jpg" data-src="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_021.jpg" alt="Cameron O&#039;Neal, pre-med sophomore, gets a picture of the Homecoming Bonfire Thursday, Oct. 19, 2017. Photo by Rachel Johnson"/></a> <div class="flagPhantom_ThumbLabel"> <span class="flagPhantom_ThumbLabel_title">Cameron O'Neal, pre-med sophomore, gets a picture of the Homecoming Bonfire Thursday, Oct. 19, 2017. Photo by Rachel Johnson</span></div> <div style="display:none;" class="flagPhantom_Details"> <div class="flagPhantom_description"> <div class="flagPhantom_title">Cameron O'Neal, pre-med sophomore, gets a picture of the Homecoming Bonfire Thursday, Oct. 19, 2017. Photo by Rachel Johnson</div> <div class="flagPhantom_text"><p>Cameron O'Neal, pre-med sophomore, gets a picture of the Homecoming Bonfire Thursday, Oct. 19, 2017. Photo by Rachel Johnson</p></div> </div> </div> </div> <div class="flagPhantom_ThumbContainer flagPhantom_ThumbLoader" data-id="2554" data-ratio="1.16761687571" data-title="Nicole Buchanan, resident assistant, and Shelby Emerson, education senior, enjoy the bonfire hosted by MSU during homecoming week at the student parking lot on Thursday, Oct. 19, 2017. Photo by Harlie David" data-views="1" data-likes="0" data-download="http://thewichitan.com/wp-content/flagallery/flames2017/flames_022.jpg" data-filename="flames_022.jpg"> <a href="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_022.jpg" class="flagPhantom_Thumb"><img src="http://thewichitan.com/wp-content/flagallery/flames2017/thumbs/thumbs_flames_022.jpg" data-src="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_022.jpg" alt="Nicole Buchanan, resident assistant, and Shelby Emerson, education senior, enjoy the bonfire hosted by MSU during homecoming week at the student parking lot on Thursday, Oct. 19, 2017. Photo by Harlie David"/></a> <div class="flagPhantom_ThumbLabel"> <span class="flagPhantom_ThumbLabel_title">Nicole Buchanan, resident assistant, and Shelby Emerson, education senior, enjoy the bonfire hosted by MSU during homecoming week at the student parking lot on Thursday, Oct. 19, 2017. Photo by Harlie David</span></div> <div style="display:none;" class="flagPhantom_Details"> <div class="flagPhantom_description"> <div class="flagPhantom_title">Nicole Buchanan, resident assistant, and Shelby Emerson, education senior, enjoy the bonfire hosted by MSU during homecoming week at the student parking lot on Thursday, Oct. 19, 2017. Photo by Harlie David</div> <div class="flagPhantom_text"><p>Nicole Buchanan, resident assistant, and Shelby Emerson, education senior, enjoy the bonfire hosted by MSU during homecoming week at the student parking lot on Thursday, Oct. 19, 2017. Photo by Harlie David</p></div> </div> </div> </div> <div class="flagPhantom_ThumbContainer flagPhantom_ThumbLoader" data-id="2555" data-ratio="1.23225030084" data-title="Malaeni Ramos, biology senior, Francisco Ramos Armas, biology senior, and Shanice Roberts, biology senior, shield themself from the heat of the Homecoming Bonfire, Thursday, Oct. 19, 2017. Photo by Rachel Johnson" data-views="0" data-likes="0" data-download="http://thewichitan.com/wp-content/flagallery/flames2017/flames_023.jpg" data-filename="flames_023.jpg"> <a href="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_023.jpg" class="flagPhantom_Thumb"><img src="http://thewichitan.com/wp-content/flagallery/flames2017/thumbs/thumbs_flames_023.jpg" data-src="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_023.jpg" alt="Malaeni Ramos, biology senior, Francisco Ramos Armas, biology senior, and Shanice Roberts, biology senior, shield themself from the heat of the Homecoming Bonfire, Thursday, Oct. 19, 2017. Photo by Rachel Johnson"/></a> <div class="flagPhantom_ThumbLabel"> <span class="flagPhantom_ThumbLabel_title">Malaeni Ramos, biology senior, Francisco Ramos Armas, biology senior, and Shanice Roberts, biology senior, shield themself from the heat of the Homecoming Bonfire, Thursday, Oct. 19, 2017. Photo by Rachel Johnson</span></div> <div style="display:none;" class="flagPhantom_Details"> <div class="flagPhantom_description"> <div class="flagPhantom_title">Malaeni Ramos, biology senior, Francisco Ramos Armas, biology senior, and Shanice Roberts, biology senior, shield themself from the heat of the Homecoming Bonfire, Thursday, Oct. 19, 2017. Photo by Rachel Johnson</div> <div class="flagPhantom_text"><p>Malaeni Ramos, biology senior, Francisco Ramos Armas, biology senior, and Shanice Roberts, biology senior, shield themself from the heat of the Homecoming Bonfire, Thursday, Oct. 19, 2017. Photo by Rachel Johnson</p></div> </div> </div> </div> <div class="flagPhantom_ThumbContainer flagPhantom_ThumbLoader" data-id="2556" data-ratio="1.27521793275" data-title="Cameron O&#039;Neal, pre-med sophomore, and Ben Williamson, non-student, enjoy the bonfire at MSU in the student parking lot on Thursday, Oct.19, 2017. Photo by Harlie David" data-views="0" data-likes="0" data-download="http://thewichitan.com/wp-content/flagallery/flames2017/flames_024.jpg" data-filename="flames_024.jpg"> <a href="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_024.jpg" class="flagPhantom_Thumb"><img src="http://thewichitan.com/wp-content/flagallery/flames2017/thumbs/thumbs_flames_024.jpg" data-src="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_024.jpg" alt="Cameron O&#039;Neal, pre-med sophomore, and Ben Williamson, non-student, enjoy the bonfire at MSU in the student parking lot on Thursday, Oct.19, 2017. Photo by Harlie David"/></a> <div class="flagPhantom_ThumbLabel"> <span class="flagPhantom_ThumbLabel_title">Cameron O'Neal, pre-med sophomore, and Ben Williamson, non-student, enjoy the bonfire at MSU in the student parking lot on Thursday, Oct.19, 2017. Photo by Harlie David</span></div> <div style="display:none;" class="flagPhantom_Details"> <div class="flagPhantom_description"> <div class="flagPhantom_title">Cameron O'Neal, pre-med sophomore, and Ben Williamson, non-student, enjoy the bonfire at MSU in the student parking lot on Thursday, Oct.19, 2017. Photo by Harlie David</div> <div class="flagPhantom_text"><p>Cameron O'Neal, pre-med sophomore, and Ben Williamson, non-student, enjoy the bonfire at MSU in the student parking lot on Thursday, Oct.19, 2017. Photo by Harlie David</p></div> </div> </div> </div> <div class="flagPhantom_ThumbContainer flagPhantom_ThumbLoader" data-id="2557" data-ratio="1" data-title="Carley Bronaugh, psychology freshman, and Jaydon Johnston, math junior, dance together as the Homecoming Bonfire burns in the background and music plays from the stage, Thursday Oct. 19, 2017. &quot;We&#039;ve been together for a year and a half. [The Bonfire] I though was really cool, it&#039;s both of our first time and it was really awesome,&quot; Bronaugh said. Photo by Rachel Johsnon" data-views="1" data-likes="0" data-download="http://thewichitan.com/wp-content/flagallery/flames2017/flames_025.jpg" data-filename="flames_025.jpg"> <a href="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_025.jpg" class="flagPhantom_Thumb"><img src="http://thewichitan.com/wp-content/flagallery/flames2017/thumbs/thumbs_flames_025.jpg" data-src="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_025.jpg" alt="Carley Bronaugh, psychology freshman, and Jaydon Johnston, math junior, dance together as the Homecoming Bonfire burns in the background and music plays from the stage, Thursday Oct. 19, 2017. &quot;We&#039;ve been together for a year and a half. [The Bonfire] I though was really cool, it&#039;s both of our first time and it was really awesome,&quot; Bronaugh said. Photo by Rachel Johsnon"/></a> <div class="flagPhantom_ThumbLabel"> <span class="flagPhantom_ThumbLabel_title">Carley Bronaugh, psychology freshman, and Jaydon Johnston, math junior, dance together as the Homecoming Bonfire burns in the background and music plays from the stage, Thursday Oct. 19, 2017. "We've been together for a year and a half. [The Bonfire] I though was really cool, it's both of our first time and it was really awesome," Bronaugh said. Photo by Rachel Johsnon</span></div> <div style="display:none;" class="flagPhantom_Details"> <div class="flagPhantom_description"> <div class="flagPhantom_title">Carley Bronaugh, psychology freshman, and Jaydon Johnston, math junior, dance together as the Homecoming Bonfire burns in the background and music plays from the stage, Thursday Oct. 19, 2017. "We've been together for a year and a half. [The Bonfire] I though was really cool, it's both of our first time and it was really awesome," Bronaugh said. Photo by Rachel Johsnon</div> <div class="flagPhantom_text"><p>Carley Bronaugh, psychology freshman, and Jaydon Johnston, math junior, dance together as the Homecoming Bonfire burns in the background and music plays from the stage, Thursday Oct. 19, 2017. "We've been together for a year and a half. [The Bonfire] I though was really cool, it's both of our first time and it was really awesome," Bronaugh said. Photo by Rachel Johsnon</p></div> </div> </div> </div> <div class="flagPhantom_ThumbContainer flagPhantom_ThumbLoader" data-id="2558" data-ratio="1.49926793558" data-title="Thursday, Oct 19, 2017 , Homecoming bonfire. Photo by Sara Keeling" data-views="0" data-likes="0" data-download="http://thewichitan.com/wp-content/flagallery/flames2017/flames_026.jpg" data-filename="flames_026.jpg"> <a href="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_026.jpg" class="flagPhantom_Thumb"><img src="http://thewichitan.com/wp-content/flagallery/flames2017/thumbs/thumbs_flames_026.jpg" data-src="http://thewichitan.com/wp-content/flagallery/flames2017/webview/flames_026.jpg" alt="Thursday, Oct 19, 2017 , Homecoming bonfire. Photo by Sara Keeling"/></a> <div class="flagPhantom_ThumbLabel"> <span class="flagPhantom_ThumbLabel_title">Thursday, Oct 19, 2017 , Homecoming bonfire. Photo by Sara Keeling</span></div> <div style="display:none;" class="flagPhantom_Details"> <div class="flagPhantom_description"> <div class="flagPhantom_title">Thursday, Oct 19, 2017 , Homecoming bonfire. Photo by Sara Keeling</div> <div class="flagPhantom_text"><p>Thursday, Oct 19, 2017 , Homecoming bonfire. Photo by Sara Keeling</p></div> </div> </div> </div> </div> </div> <script type="text/javascript"> jQuery(function(){ var settings = {"maxheight":"0","thumbCols":"0","thumbRows":"0","thumbsNavigation":"scroll","bgColor":"#ffffff","bgAlpha":"0","thumbWidth":"200","thumbHeight":"180","thumbWidthMobile":"150","thumbHeightMobile":"135","thumbsSpacing":"8","thumbsVerticalPadding":"4","thumbsHorizontalPadding":"4","thumbsAlign":"center","thumbScale":"1","thumbBG":"#ffffff","thumbAlpha":"90","thumbAlphaHover":"100","thumbBorderSize":"1","thumbBorderColor":"#cccccc","thumbPadding":"2","thumbsInfo":"label","labelOnHover":"1","labelTextColor":"#ffffff","labelLinkColor":"#e7e179","label8TextColor":"#0b0b0b","label8LinkColor":"#3695E7","tooltipTextColor":"#0b0b0b","tooltipBgColor":"#ffffff","tooltipStrokeColor":"#000000","lightboxControlsColor":"#ffffff","lightboxTitleColor":"#f3f3f3","lightboxTextColor":"#f3f3f3","lightboxBGColor":"#0b0b0b","lightboxBGAlpha":"80","socialShareEnabled":"1","deepLinks":"1","sidebarBGColor":"#ffffff","lightbox800HideArrows":"0","viewsEnabled":"1","likesEnabled":"1","thumb2link":"0","show_title":"1","show_download_button":"1","initRPdelay":"200","key":"","name":"","mfp_css":"\r\n#mfp_gm_sc1_161 .mfp-arrow-right:after,\r\n#mfp_gm_sc1_161 .mfp-arrow-right .mfp-a {border-left-color:#ffffff;}\r\n#mfp_gm_sc1_161 .mfp-arrow-left:after,\r\n#mfp_gm_sc1_161 .mfp-arrow-left .mfp-a {border-right-color:#ffffff;}\r\n#mfp_gm_sc1_161 .mfp-close,\r\n#mfp_gm_sc1_161 .mfp-likes,\r\n#mfp_gm_sc1_161 .mfp-share {color:#ffffff;}\r\n#mfp_gm_sc1_161 .mfp-preloader {background-color:#ffffff;}\r\n#mfp_gm_sc1_161 .flagPhantom_title,\r\n#mfp_gm_sc1_161 .mfp-counter {color:#f3f3f3;}\r\n#mfp_gm_sc1_161 .flagPhantom_text {color:#f3f3f3;}\r\n#mfp_gm_sc1_161_bg.mfp-bg {background-color:#0b0b0b;}\r\n#mfp_gm_sc1_161_bg.mfp-bg {opacity:0.8;}\r\n#mfp_gm_sc1_161_bg.mfp-zoom-in.mfp-bg {opacity:0}\r\n#mfp_gm_sc1_161_bg.mfp-zoom-in.mfp-ready.mfp-bg {opacity:0.8;}\r\n#mfp_gm_sc1_161_bg.mfp-zoom-in.mfp-removing.mfp-bg {opacity:0}"}; jQuery('#FlaGallery_sc1_161').flagPhantom([settings]); }); </script></div></p>
<!--<rdf:RDF xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
			xmlns:dc="http://purl.org/dc/elements/1.1/"
			xmlns:trackback="http://madskills.com/public/xml/rss/module/trackback/">
		<rdf:Description rdf:about="http://thewichitan.com/450-flames-light-torch-parade/"
    dc:identifier="http://thewichitan.com/450-flames-light-torch-parade/"
    dc:title="450 flames light torch parade"
    trackback:ping="http://thewichitan.com/450-flames-light-torch-parade/trackback/" />
</rdf:RDF>-->
</div><div class="post-meta"><span class="categories">Filed Under: <a href="http://thewichitan.com/category/news/campus/" rel="category tag">Campus</a>, <a href="http://thewichitan.com/category/news/" rel="category tag">News</a></span> <span class="tags">Tagged With: <a href="http://thewichitan.com/tag/bonfire/" rel="tag">bonfire</a>, <a href="http://thewichitan.com/tag/homecoming/" rel="tag">homecoming</a>, <a href="http://thewichitan.com/tag/lip-sync/" rel="tag">lip sync</a>, <a href="http://thewichitan.com/tag/midwestern-state/" rel="tag">midwestern state</a>, <a href="http://thewichitan.com/tag/torches/" rel="tag">torches</a>, <a href="http://thewichitan.com/tag/torchlight-parade/" rel="tag">torchlight parade</a></span></div></div>	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Speak Your Mind <small><a rel="nofollow" id="cancel-comment-reply-link" href="/450-flames-light-torch-parade/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="http://thewichitan.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
				<p class="comment-form-comment"><textarea id="comment" name="comment" cols="45" rows="8" tabindex="4" aria-required="true"></textarea></p><p class="comment-form-author"><input id="author" name="author" type="text" value="" size="30" tabindex="1" aria-required="true" /><label for="author">Name</label> <span class="required">*</span></p>
<p class="comment-form-email"><input id="email" name="email" type="text" value="" size="30" tabindex="2" aria-required="true" /><label for="email">Email</label> <span class="required">*</span></p>
<p class="comment-form-url"><input id="url" name="url" type="text" value="" size="30" tabindex="3" /><label for="url">Website</label></p>
<input type="hidden" id="mp_sbg_email" name="mp_sbg_email" value="" /><div id="mp_sbg_insert"></div>		<script>
		document.getElementById('mp_sbg_insert').innerHTML += '<label for="mp_sbg_checkbox">Please check to prove YOU ARE human. Thank you.<br /></label><input type="checkbox" id="mp_sbg_checkbox" name="mp_sbg_checkbox" />';
		</script>
		<noscript>
		<input type="hidden" id="mp_sbg_checkbox" name="mp_sbg_checkbox" value="" /><label for='mp_sbg_pw'>Please copy this password:</label><input type='text' id='mp_sbg_pw' name='mp_sbg_pw' value='mp59ea18da2a491' /><label for='mp_sbg_cpw'>Please paste the password here:</label><input type='text' id='mp_sbg_cpw' name='mp_sbg_cpw' value='' />		</noscript>
		<input type="hidden" id="mp_sbg_facebook" name="mp_sbg_facebook" value="" /><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='43967' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="111be742c4" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="124"/></p>			</form>
			</div><!-- #respond -->
	</div><div id="sidebar" class="sidebar widget-area"><div id="text-14" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Advertisement</h4>
			<div class="textwidget"><a href="https://firstbankweb.com/" target="_blank"><img src="http://thewichitan.com/wp-content/uploads/2017/05/FirstBank_small.jpg"></a>
</p>
<center><a href="https://firstbankweb.com/" target="_blank"><b>FIRST BANK – WE'RE HERE FOR YOU AND MSU</b></a></BR>Walking distance from campus and Sikes Senter Mall, 2801 Midwestern Parkway at Maplewood</center><p></div>
		</div></div>
<div id="text-15" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">View the most recent issue</h4>
			<div class="textwidget"><div data-configid="1966839/54392466" style="width:100%; height:300px;" class="issuuembed"></div>
<script type="text/javascript" src="//e.issuu.com/embed.js" async="true"></script></div>
		</div></div>
		<div id="recent-posts-5" class="widget widget_recent_entries"><div class="widget-wrap">		<h4 class="widget-title widgettitle">Recent Posts</h4>
		<ul>
					<li>
				<a href="http://thewichitan.com/450-flames-light-torch-parade/">450 flames light torch parade</a>
							<span class="post-date">October 20, 2017</span>
						</li>
					<li>
				<a href="http://thewichitan.com/torchlight-bonfire-fall17/">Freshman: &#8216;This is my first bonfire and I expect it to be lit&#8217;</a>
							<span class="post-date">October 20, 2017</span>
						</li>
					<li>
				<a href="http://thewichitan.com/men-defeat-st-edwards-1-0/">Men defeat St. Edward&#8217;s 1-0</a>
							<span class="post-date">October 20, 2017</span>
						</li>
					<li>
				<a href="http://thewichitan.com/field-day-competitions-photo-gallery/">Field Day competitions photo gallery</a>
							<span class="post-date">October 19, 2017</span>
						</li>
					<li>
				<a href="http://thewichitan.com/upb-host-comedian-john-cassidy/">UPB to host comedian John Cassidy Oct. 20</a>
							<span class="post-date">October 19, 2017</span>
						</li>
					<li>
				<a href="http://thewichitan.com/homecoming-danceoct-18/">Students let loose at homecoming dance Oct. 18</a>
							<span class="post-date">October 19, 2017</span>
						</li>
					<li>
				<a href="http://thewichitan.com/smoking-not-lighting-cigarette/">Smoking: not just lighting up a cigarette</a>
							<span class="post-date">October 19, 2017</span>
						</li>
					<li>
				<a href="http://thewichitan.com/mens-soccer-st-edwards-thursday/">Men&#8217;s soccer to play St. Edward&#8217;s Thursday</a>
							<span class="post-date">October 18, 2017</span>
						</li>
					<li>
				<a href="http://thewichitan.com/hoco-rep-quote-collection/">Meet your homecoming court</a>
							<span class="post-date">October 18, 2017</span>
						</li>
					<li>
				<a href="http://thewichitan.com/msu-rewind-photo-booth-available-students-week/">Photo booth available to students all week</a>
							<span class="post-date">October 18, 2017</span>
						</li>
				</ul>
		</div></div>
		<div id="recent-comments-7" class="widget widget_recent_comments"><div class="widget-wrap"><h4 class="widget-title widgettitle">Recent comments</h4>
<ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">Me</span> on <a href="http://thewichitan.com/josh-buchel-south-africa-17/comment-page-1/#comment-151545">&#8216;If you&#8217;re from Africa, why are you white?&#8217;</a></li><li class="recentcomments"><span class="comment-author-link">Damian</span> on <a href="http://thewichitan.com/josh-buchel-south-africa-17/comment-page-1/#comment-151540">&#8216;If you&#8217;re from Africa, why are you white?&#8217;</a></li><li class="recentcomments"><span class="comment-author-link">Amy</span> on <a href="http://thewichitan.com/josh-buchel-south-africa-17/comment-page-1/#comment-151539">&#8216;If you&#8217;re from Africa, why are you white?&#8217;</a></li><li class="recentcomments"><span class="comment-author-link">Jill</span> on <a href="http://thewichitan.com/josh-buchel-south-africa-17/comment-page-1/#comment-151537">&#8216;If you&#8217;re from Africa, why are you white?&#8217;</a></li><li class="recentcomments"><span class="comment-author-link">En</span> on <a href="http://thewichitan.com/josh-buchel-south-africa-17/comment-page-1/#comment-151536">&#8216;If you&#8217;re from Africa, why are you white?&#8217;</a></li></ul></div></div>
<div class="sidebar-bottom-left"></div><!-- end #sidebar-bottom-left--><div class="sidebar-bottom-right"></div><!-- end #sidebar-bottom-right--></div></div></div><div id="footer-widgets" class="footer-widgets"><div class="wrap"><div class="widget-area footer-widgets-1 footer-widget-area"><div id="text-6" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><p>
<p>
<p>
<div id="CampusAveAPI_Recent_Listings_Container" partnerid="2370" format="large">Loading Recent Classifieds...</div>
<p> <script type="text/javascript" src="http://www.campusave.com/includes/api.recent.js"></script></p>
</div>
		</div></div>
</div><div class="widget-area footer-widgets-2 footer-widget-area"><div id="text-8" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Like us on Facebook</h4>
			<div class="textwidget"><div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/all.js#xfbml=1&appId=219885354706681";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>
<div class="fb-like-box" data-href="https://www.facebook.com/thewichitan" data-width="290" data-height="290" data-show-faces="true" data-border-color="707070" data-stream="false" data-header="false"></div></div>
		</div></div>
</div><div class="widget-area footer-widgets-3 footer-widget-area"><div id="calendar-4" class="widget widget_calendar"><div class="widget-wrap"><h4 class="widget-title widgettitle">Calendar</h4>
<div id="calendar_wrap" class="calendar_wrap"><table id="wp-calendar">
	<caption>October 2017</caption>
	<thead>
	<tr>
		<th scope="col" title="Monday">M</th>
		<th scope="col" title="Tuesday">T</th>
		<th scope="col" title="Wednesday">W</th>
		<th scope="col" title="Thursday">T</th>
		<th scope="col" title="Friday">F</th>
		<th scope="col" title="Saturday">S</th>
		<th scope="col" title="Sunday">S</th>
	</tr>
	</thead>

	<tfoot>
	<tr>
		<td colspan="3" id="prev"><a href="http://thewichitan.com/2017/09/">&laquo; Sep</a></td>
		<td class="pad">&nbsp;</td>
		<td colspan="3" id="next" class="pad">&nbsp;</td>
	</tr>
	</tfoot>

	<tbody>
	<tr>
		<td colspan="6" class="pad">&nbsp;</td><td>1</td>
	</tr>
	<tr>
		<td><a href="http://thewichitan.com/2017/10/02/" aria-label="Posts published on October 2, 2017">2</a></td><td><a href="http://thewichitan.com/2017/10/03/" aria-label="Posts published on October 3, 2017">3</a></td><td><a href="http://thewichitan.com/2017/10/04/" aria-label="Posts published on October 4, 2017">4</a></td><td><a href="http://thewichitan.com/2017/10/05/" aria-label="Posts published on October 5, 2017">5</a></td><td><a href="http://thewichitan.com/2017/10/06/" aria-label="Posts published on October 6, 2017">6</a></td><td>7</td><td>8</td>
	</tr>
	<tr>
		<td><a href="http://thewichitan.com/2017/10/09/" aria-label="Posts published on October 9, 2017">9</a></td><td><a href="http://thewichitan.com/2017/10/10/" aria-label="Posts published on October 10, 2017">10</a></td><td><a href="http://thewichitan.com/2017/10/11/" aria-label="Posts published on October 11, 2017">11</a></td><td><a href="http://thewichitan.com/2017/10/12/" aria-label="Posts published on October 12, 2017">12</a></td><td><a href="http://thewichitan.com/2017/10/13/" aria-label="Posts published on October 13, 2017">13</a></td><td><a href="http://thewichitan.com/2017/10/14/" aria-label="Posts published on October 14, 2017">14</a></td><td><a href="http://thewichitan.com/2017/10/15/" aria-label="Posts published on October 15, 2017">15</a></td>
	</tr>
	<tr>
		<td><a href="http://thewichitan.com/2017/10/16/" aria-label="Posts published on October 16, 2017">16</a></td><td><a href="http://thewichitan.com/2017/10/17/" aria-label="Posts published on October 17, 2017">17</a></td><td><a href="http://thewichitan.com/2017/10/18/" aria-label="Posts published on October 18, 2017">18</a></td><td><a href="http://thewichitan.com/2017/10/19/" aria-label="Posts published on October 19, 2017">19</a></td><td id="today"><a href="http://thewichitan.com/2017/10/20/" aria-label="Posts published on October 20, 2017">20</a></td><td>21</td><td>22</td>
	</tr>
	<tr>
		<td>23</td><td>24</td><td>25</td><td>26</td><td>27</td><td>28</td><td>29</td>
	</tr>
	<tr>
		<td>30</td><td>31</td>
		<td class="pad" colspan="5">&nbsp;</td>
	</tr>
	</tbody>
	</table></div></div></div>
</div></div></div><div id="footer" class="footer"><div class="wrap"><div class="gototop"><p><a href="#wrap" rel="nofollow">Return to top of page</a></p></div><div class="creds"><p>Copyright &#x000A9;&nbsp;2017 &#x000B7; <a href="http://www.studiopress.com/themes/lifestyle">Lifestyle Theme</a> on <a href="http://www.studiopress.com/">Genesis Framework</a> &#x000B7; <a href="http://wordpress.org/">WordPress</a> &#x000B7; <a rel="nofollow" href="http://thewichitan.com/wp-login.php">Log in</a></p></div></div></div></div><script type='text/javascript'>jQuery(document).ready(function($) {$(".flexslider").flexslider({controlsContainer: "#genesis-responsive-slider",animation: "slide",directionNav: 1,controlNav: 1,animationDuration: 800,slideshowSpeed: 4000    });  });</script><link rel='stylesheet' id='magnific-popup-css'  href='http://thewichitan.com/wp-content/plugins/flash-album-gallery/assets/mag-popup/magnific-popup.css?ver=1.1.0' type='text/css' media='screen' />
<link rel='stylesheet' id='flagallery-phantom-skin-css'  href='http://thewichitan.com/wp-content/plugins/flagallery-skins/phantom/css/phantom.css?ver=1.0' type='text/css' media='all' />
<script type='text/javascript' src='http://thewichitan.com/wp-includes/js/hoverIntent.min.js?ver=1.8.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var FlaGallery = {"ajaxurl":"http:\/\/thewichitan.com\/wp-admin\/admin-ajax.php","nonce":"c7fa587249","license":"","pack":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://thewichitan.com/wp-content/plugins/flash-album-gallery/assets/script.js?ver=5.1.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"http:\/\/thewichitan.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://thewichitan.com/wp-content/plugins/wp-polls/polls-js.js?ver=2.73.7'></script>
<script type='text/javascript' src='http://thewichitan.com/wp-includes/js/comment-reply.min.js?ver=4.8.2'></script>
<script type='text/javascript' src='http://thewichitan.com/wp-content/plugins/genesis-responsive-slider/js/jquery.flexslider.js?ver=0.9.5'></script>
<script type='text/javascript' src='http://thewichitan.com/wp-includes/js/wp-embed.min.js?ver=4.8.2'></script>
<script type='text/javascript' src='http://thewichitan.com/wp-content/plugins/flash-album-gallery/assets/mag-popup/jquery.magnific-popup.min.js?ver=1.1.0'></script>
<script type='text/javascript' src='http://thewichitan.com/wp-content/plugins/flagallery-skins/phantom/js/phantom.js?ver=1.0'></script>
<script type='text/javascript' src='http://thewichitan.com/wp-content/plugins/akismet/_inc/form.js?ver=4.0'></script>
</body></html>

<!-- Dynamic page generated in 1.071 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2017-10-20 10:40:10 -->

<!-- super cache -->